AGG Software
Задать вопрос  В начало  Назад  Дальше

Главное меню программы


Меню File (Файл)

 

File | New (Ctrl+N) - команда запускает мастер создания нового окна.

 

File | Open (Ctrl+O) - команда позволяет открыть двоичный лог-файл Advanced USB Port Monitor, который был создан ранее для какого-либо устройства. Будет открыто окно мониторинга для данного устройства. Однако если в данный момент устройство не подключено, то невозможно будет продолжить мониторинг в данный лог-файл.

 

File | Save (Ctrl+S) - данный пункт меню активируется только если в данный момент активно окно мониторинга и позволяет задать новое имя для двоичного лог-файла. Имя файла будет запрошено в отдельном диалоговом окне. Если до этого был открыт другой лог-файл, то будет предложено скопировать его содержимое в новый файл.

 

File | Save as - данный пункт меню активируется только если в данный момент активно окно мониторинга и позволяет сохранить часть данных (необходимо выделить несколько пакетов данных в окне мониторинга) или все данные в окне мониторинга двоичный лог-файл или XML файл. Перед сохранением данных будет запрошен тип файл и его имя в отдельном диалоговом окне.

 

File | Close - данный пункт меню активируется только если в данный момент активно какое-либо окно в программе и позволяет закрыть активное окно.

 

File | Close all - данный пункт меню активируется только если в программе открыты какие-либо окна и позволяет закрыть все открытые окна одним кликом мыши.

 

File | Open workspace - команда открывает диалоговое окно со списком рабочих пространств. Более подробно эта и последующие команды по работе с рабочим пространством описаны в разделе Рабочее пространство.

 

File | Save workspace - команда активируется только если ранее было загружено какое-либо рабочее пространство и позволяет сохранить все изменения в рабочем пространстве, которые были сделаны.

 

File | Save workspace as - команда позволяет сохранить рабочее пространство под новым именем.

 

File | Delete workspaces - команда открывает диалоговое окно со списком рабочих пространств, которые вы можете удалить.

 

File | Open workspace in file - команда открывает диалоговое окно в котором вы может выбрать файл с рабочим пространством на диске.

 

File | Save workspace to file - команда открывает диалоговое окно в котором вы может задать путь и имя файла в котором будет сохранено  рабочее пространство на диске.

 

File | Open last workspace on startup - данная опция указывает программе, что при следующем запуске необходимо загружать рабочее пространство, которое было активно во время последнего использовании программы. Если никакое рабочее пространство не использовалось ранее, то при старте данная опция игнорируется.

 

File | Print - данный пункт меню активируется только если в данный момент активно окно информации (информация об устройстве, об URB и т.п.) и выводит на печать содержимое этого окна с текущим параметрами принтера.

 

File | Print setup - команда открывает стандартное окно настройки параметров печати. В дальнейшем эти параметры будут использоваться при вызове команды Print.

 

File | Exit - команда позволяет покинуть программу. При выходе из программы будет сохранено положение главное окна программы.

 

 

warning

 

 

Замечание: Если было открыто рабочее пространство, то изменения в нем не будут сохранены.

 

Меню Edit

 

Edit | Copy (Ctrl+C) - данный пункт меню активируется только если в данный момент активно окно мониторинга и в нем выбран один или несколько пакетов данных. Команда копирует выделенные элементы в буфер обмена (Clipboard).

 

Edit | Select all (Ctrl+A) - данный пункт меню активируется только если в данный момент активно окно мониторинга и в нем есть хотя бы один пакет данных. Команда выделяет все пакеты данных. В дальнейшем можно скопировать эти пакеты данных в буфер обмена или сохранить в файл.

 

Edit | Find (Ctrl+F) - данный пункт меню активируется только если в данный момент активно окно мониторинга и позволяет осуществлять поиск по тексту в окне. После вызова данной команды открывается окно (рис.1) в котором вы можете задать параметры поиска.

 

Find-window

Рис.1 Окно параметров поиска

 

 

Text to find - текст, который требуется найти;

 

Options - здесь указываются атрибуты строки поиска

 

Case sensitive - учитывать различия между строчными и заглавными буквами при поиске;
Whole words only - поиск целых слов. Если данная опция отключена, то поиск текста будет осуществляться внутри длинных слов.

 

Direction - направление поиска текста
 

Forward - поиск от текущей позиции до конца файла;
Backward - поиск от текущей позиции до начала файла.

 

Scope - задается количество данных для поиска

 

Global - искать текст среди всех пакетов данных (начиная с указанного начала поиска);
Selected - искать текст только среди выделенных пакетов данных.

 

Origin - задается начальная позиция поиска

 

From cursor - искать начиная с позиции курсора;
Entire scope - искать среди всех данных в окне.

 

После нажатия кнопки OK программа попробует найти указанный текст. Если текст будет найден, то фокус в окне мониторинга будет перемещен к найденному пакету данных и найденный текст будет подсвечен цветом, заданным в опциях программы. Чтобы найти следующее включение текста, необходимо нажать F3. Если текст не был найден, то будет выведено соответствующее сообщение.

 

Edit | Find next (F3) - повтор поиска с теми же параметрами.

 

 

warning

 

 

Замечание: Команды Copy, Find, Find next работают только с текстом, который вы видите на экране. Если текущий вид данных не отображает какой-либо текст, то указанные операции с ним производиться не будут.

 

 

Edit | Properties - команда вызывает диалоговое окно редактирования опций программы.

 

Меню View

 

View | Show connected devices only - данная опция включает/выключает отображение только подключенных устройств в окне USB устройств. Т.е. если эта опция включена, то в окне USB устройств не будут отображаться USB порты без подключенных устройств.

 

View | Hide host controllers without devices - данная опция активируется только при включенной предыдущей опции и включает/выключает отображение хост-контроллеров в окне USB устройств без подключенных устройств. Т.е. если эта опция включена, то в окне USB устройств не будут отображаться хост-контроллеры без подключенных устройств.

 

View | Auto refresh USBs tree - данная опция включает/выключает автоматическое обновление списка устройств в окне USB устройств при подключении и отключении вами USB устройств. При включенной опции список будет обновляться через несколько секунд после полной инициализации и готовности USB устройства. Если данная опция выключена, то вы должны будете нажимать кнопку "Обновить" в окне USB устройств.

 

View | Auto scroll - данная опция включает/отключает автоматическую прокрутку в окне мониторинга при поступлении новых данных. При включенной опции фокус в окне мониторинга будет автоматически перемещен на новый пакет данных при его добавлении в окно мониторинга. При выключенной опции фокус в окне мониторинга будет оставаться неизменным.

 

 

warning

 

 

Замечание: Данная опция требует существенных ресурсов процессора, поскольку при прокрутке осуществляется декодирование пакета данных, его отображение на экране и вычисление позиции полосы прокрутки. При интенсивном потоке данных рекомендуется отключать данную опцию.

 

 

 

View | Toolbars - данное подменю позволяет включить/ выключить отображение дополнительных панелей в главном окне программы.

 

View | Toolbars | Task bar - команда включает/отключает отображение панели задач в главном окне программы.

 

View | Toolbars | Status bar - команда включает/отключает отображение панели статуса в главном окне программы.

 

Меню Tools

 

Tools | Open monitor window - команда открывает окно мониторинга с параметрами по умолчанию.

 

Tools | Open waiting monitor window - команда открывает окно мониторинга, которое будет ожидать подключение нового устройства. Как только устройство будет подключено, автоматически начнется захват данных от этого устройства.

 

Tools | Open performance monitor window - команда открывает окно теста производительности с параметрами по умолчанию.

 

Tools | Show details - команда открывает окно информации об устройстве.

 

Tools | Fast replug - команда выполняет программную реинициализацию устройства, что равносильно его безопасному извлечению из компьютера, а затем его подключению. Это может потребоваться, если вы хотите захватить данные, которыми обмениваются компьютер и устройство во время инициализации USB устройства или если по каким то причинам вы изменили конфигурацию драйвера-фильтра Advanced SUB Monitor.

 

 

warning

 

 

Замечание: В некоторых случаях невозможно выполнить это действие, о чем будет выведено соответствующее сообщение. В этом случае рекомендуется вынуть разъем устройства из USB порта, подождать несколько секунд и воткнуть устройство в тот же порт USB.

 

 

Tools | Save as Microsoft Word document - данный пункт меню активируется только если в данный момент активно окно информации (информация об устройстве, об URB и т.п.) и позволяет сохранить отчет в формате Microsoft Word document. При вызове данной команды будет показано диалоговое окна, в котором вы должны будете указать имя файла.

 

Tools | Save as PDF file - данный пункт меню активируется только если в данный момент активно окно информации (информация об устройстве, об URB и т.п.) и позволяет сохранить отчет в формате Adobe PDF. При вызове данной команды будет показано диалоговое окна, в котором вы должны будете указать имя файла.

 

Tools | Export to XML - данный пункт меню активируется только если в данный момент активно окно мониторинга и позволяет экспортировать данные в окне мониторинга в XML файл. Эта команда аналогична команде File | Save за исключением того, что сохранить данные можно только в XML файл.

 

Advanced features - команды по работе с драйвером позволяют выбрать параметры установки драйвера. Это может потребоваться, когда вы хотите удалить, перерегистрировать драйвер в системе или отключить его для какого-либо устройства.

 

 

warning

 

 

Замечание: Следует осторожно пользоваться командами управления драйвером. Т.к. незарегистрированный или неверно установленный драйвер лишает работоспособности 90% функций программы.

 

 

Tools | Install driver service - команда регистрирует драйвер в вашей системе. Производятся все действия необходимые для нормального функционирования драйвера в качестве драйвера-фильтра (filter driver).

 

Tools | Remove driver service - команда удаляет регистрационную информацию о драйвере из вашей системы. Данная команда не удаляет информацию об установленных драйверах-фильтрах. Поэтому это может привести к не работоспособности вашего USB устройства. Перед вызовом данной команды рекомендуется убедиться, что драйвер-фильтр удален для всех USB устройств. Для этого необходимо нажать правую кнопку мыши на каждом USB устройстве и хост-контроллере и убедиться, что пункты Remove class filter driver и Remove device filter driver неактивны.

 

Tools | Install class filter driver - команда активируется если в списке USB устройств выбрано USB устройство, хаб или хост-контроллер, при этом не установлен другой драйвер-фильтр устройства и активирует драйвер-фильтр для всех USB устройств в вашей системе. Именно таким способом устанавливается драйвер-фильтр при инсталляции программы и рекомендуется для использования большинству пользователей. Небольшим недостатком такого способа является то, что работа драйвер-фильтра сказывается (пусть и незначительно) на работе всех USB устройств. После выполнения данной команды необходимо перезагрузить компьютер для активации драйвера.

 

Tools | Remove class filter driver - команда активируется если в списке USB устройств выбрано USB устройство, хаб или хост-контроллер, при этом установлен драйвер-фильтр класса и удаляет драйвер-фильтр класса для всех USB устройств в вашей системе. Выполнение данной команды может потребоваться, если вы хотите использовать драйвер-фильтр устройства для каждого USB устройства в отдельности. После выполнения данной команды необходимо перезагрузить компьютер для активации драйвера.

 

 

warning

 

 

Замечание: После выполнения команд по установке или удалению драйвер-фильтра класса необходимо перезагрузить компьютер, чтобы сделанные изменения вступили в силу. До перезагрузки компьютера окно мониторинга не будет захватывать данные.

 

 

Tools | Install device filter driver - команда активируется если в списке USB устройств выбрано подключенное USB устройство, при этом не установлен драйвер-фильтр другого типа и активирует драйвер-фильтр для данного USB устройства. При таком способе установки драйвер-фильтра работа драйвера сказывается только на работе данного устройства. Недостатком данного способа является то, что операцию по установке драйвера нужно производить для каждого нового устройства или если ваше USB устройство было подключено к другому USB порту. После выполнения данной команды необходимо переподключить USB устройство для активации драйвера. Можно воспользоваться командой Tools | Fast replug, чтобы избежать ручных операций по переподключению USB устройства.

 

Tools | Remove device filter driver - команда активируется если в списке USB устройств выбрано подключенное USB устройство, при этом не установлен драйвер-фильтр данного типа и удаляет драйвер-фильтр для данного USB устройства. После выполнения данной команды необходимо переподключить USB устройство для активации драйвера. Можно воспользоваться командой Tools | Fast replug, чтобы избежать ручных операций по переподключению USB устройства.

 

 

warning

 

 

Замечание: При деинсталляции программа автоматически удаляет всю информацию о драйвере (как и сам драйвер) из вашей системы. Поэтому не требуется делать это вручную, если вы хотите удалить нашу программу.

 

 

Меню Window

 

Window | USB devices - команда отображает/скрывает окно со списком USB устройств.

 

Window | Cascade - команда располагает все дочерние окна каскадом.

 

Window | Tile vertically - команда располагает все дочерние окна равномерно по вертикали.

 

Window | Tile horizontally - команда располагает все дочерние окна равномерно по горизонтали.

 

Window | Minimize all - команда сворачивает все дочерние окна.

 

Window | Arrange icons - команда располагает все свернутые дочерние окна по порядку внизу окна.

 

Меню Help

 

Help | Content - команда открывает содержание файла справки.

 

Help | Tip of day - команда отображает окно с советом дня, которое появляется после первого запуска программы.

 

Help | About - команда отображает окно "О программе", в котором отображается номер версии программы и регистрационное имя.

 

Help | Registration online - команда запускает браузер и направляет его на ссылку регистрации программы.



Задать вопрос о данном разделе


Если вы нашли несоответствие в разделе или хотите спросить о данном программном продукте, то заполните форму и нажмите кнопку "Отправить"
Пожалуйста, укажите ваш вопрос здесь:
Ваш e-mail:
и ваше имя:
Пожалуйста, задавайте вопросы только по Advanced USB Port Monitor.

Copyright © 1999-2007, AGG Software.
All rights reserved.